Colonnade engine/frame/body grounds

Stocker

New member
Sep 13, 2020
2
0
1
The Land of Sky-Blue Waters
Hi all, glad to see this website is back.

I'm trying to work through an electrical issue in my '77 Cutlass, and I can't seem to find any ground straps between the engine and the frame or body, nor from the body to the frame. The factory service manual is of no help. I assume there's supposed to be something beyond just the two going to the battery - anyone know where they'd've been?
 

Matt69olds

Active member
Oct 8, 2018
105
108
43
Kokomo Indiana
There was probably a 10-12 gauge pigtail that went from the negative battery terminal to the body. There was probably also a heavy cable or braided cable the went from a bolt on the intake or bellhousing bolt to the body. If there isn’t one now, it would be pretty easy to add. Get a couple feet of 12 gauge wire and some ring terminals that fit the battery cable, bellhousing/intake bolts (3/8 most likely) some heat shrink and solder. Use the proper crimpers, put a ring terminal on the wire, add a tab of solder to the connection, slip on the heat shrink, add the terminal to the other end. Obviously, make sure you put the heat shrink on the wire BEFORE crimping the terminal in place.
 

Stocker

New member
Thread starter
Sep 13, 2020
2
0
1
The Land of Sky-Blue Waters
The battery-to-body connection is present and seems good. There definitely isn't a cable on a bellhousing bolt since the transmission was just out to be re-sealed, and there wasn't anything there. I'll have to look one more time to confirm that there isn't anything coming from an intake bolt, and if not then find a good place on the firewall to fasten a replacement cable to.
 

Similar threads