Anyone have Qjet choke linkage bend and jam?

Olds 307 and 403

Active member
Oct 4, 2018
212
65
28
Melville, Saskatchewan
Well, I have had the link that goes to the choke plate bend twice in a month. I have it fixed again but there is no fast idle and the choke still isn't right. I am considering going and spending 2 grand in Canadian $ to get the Sniper EFI, I hate how it runs cold now . The car runs perfect warm and was running great cold till the linkage bent twice. Thoughts?
 

Eightupman

Moderator
Oct 3, 2018
43
23
8
Ladson, SC
Well, I have had the link that goes to the choke plate bend twice in a month. I have it fixed again but there is no fast idle and the choke still isn't right. I am considering going and spending 2 grand in Canadian $ to get the Sniper EFI, I hate how it runs cold now . The car runs perfect warm and was running great cold till the linkage bent twice. Thoughts?
The choke spring isn't strong enough to bend that rod. Something is binding or put together incorrectly. Got some pics of the choke area?
 
  • Like
Reactions: 1bad79

Olds 307 and 403

Active member
Oct 4, 2018
212
65
28
Melville, Saskatchewan
I will try this morning. Ken from Everyday Performance built this carb 2 years ago, it has run great. He and I are both stumped. He sent me replacement parts twice, once free. I had one bend years ago at the fast idle cam but never that rod. It bend the rods so much that it actually binds the plate from the rod contacting inside the carb. Plus my choke pull off won't contact properly either. Just bizarre and pisses me off. How is my 260 powered 88 Cutlass my best running Olds and my best running personal vehicle. The Challenger is my Wife's, what a fun car and the Tercel is my Daughter's to drive, it runs better with 375,000 km. I want my 70 to be a go everywhere car, that is why the Sniper is so tempting but our dollar blows right now, making it even pricer.
 
  • Like
Reactions: Rktpwrd

DoubleV

New member
Oct 4, 2018
12
3
3
Ohio
Since this issue is obviously not normal, then there should definitely be a permanent fix for it. Would like to see pics.

I want to like all these aftermarket self learning EFI units but I would in no way ever trust them for reliability over a qjet.

On a semi related note, the Sniper now comes in a spread bore like a qjet so that's kinda cool.
 
  • Like
Reactions: W-Dave

Olds 307 and 403

Active member
Oct 4, 2018
212
65
28
Melville, Saskatchewan
Yah the spreadbore Sniper is cool but $250 US more. Curious how reliable their electronic's will be. Here are some linkage pics.
 

Attachments

DoubleV

New member
Oct 4, 2018
12
3
3
Ohio
I see things not lined up right but it's hard to see what's causing it. I would compare your carb to a similar known good one.
 

Olds 307 and 403

Active member
Oct 4, 2018
212
65
28
Melville, Saskatchewan
I agree something is off. I may pick up another carb for parts.
 

Eightupman

Moderator
Oct 3, 2018
43
23
8
Ladson, SC
There is def something wrong... I see what appears to be some metal plate or something holding the fast idle in the wrong spot.
 

Olds 307 and 403

Active member
Oct 4, 2018
212
65
28
Melville, Saskatchewan
Which picture and where exactly are you talking about?
 

Olds 307 and 403

Active member
Oct 4, 2018
212
65
28
Melville, Saskatchewan
I think the fast cam is out of position.
 

Attachments

Olds 307 and 403

Active member
Oct 4, 2018
212
65
28
Melville, Saskatchewan
Well after about 2 hours fucking around I put most of the original parts back except the rods and 2 links, it seems to fit together better some how. Will see how long it lasts.
 
Last edited:

Matt69olds

Member
Oct 8, 2018
81
62
18
Kokomo Indiana
is the fast idle cam on the wrong side of the linkage? What are the odds your bending the link when you go wide open throttle? Is the choke linkage hitting the air cleaner? Does the choke work correctly now? Without having a Q-Jet in front of me to brainstorm I’m just “swagging” it. I know with the choke on and you floor the throttle it’s suppose to crack open the choke flap “clear flood mode”. Does the choke close when it’s cold and you hit the throttle? The choke pull off doesn’t look right either
 

Olds 307 and 403

Active member
Oct 4, 2018
212
65
28
Melville, Saskatchewan
That older linkage just didn't line up like it should. Yes the Choke pull off was messed up, stole one off the 88 for now. For some reason it would not grab the choke pull off link, now it does. All bizarre and hopefully stays fixed. Everything is tight and functions as it should. Weird all the linkage is now tight, the fast idle cam was slightly bent now is working fine, I made sure it was properly in line.
 

DoubleV

New member
Oct 4, 2018
12
3
3
Ohio
No need to switch to EFI now!
 

Olds 307 and 403

Active member
Oct 4, 2018
212
65
28
Melville, Saskatchewan
Yeah considering my Qjet runs really smooth everywhere else and should be able pull 20 mpg, why bother. I just need more stall or a manual swap to make it as snappy off the line as I want it.